[Rd] Problem with compiling - Freebsd on AMD64 (PR#7489)

kjblack at gmail.com kjblack at gmail.com
Mon Jan 10 15:22:03 CET 2005

Full_Name: Kelly Black
Version: 2.0.1
OS: FreeBSD 5.3 on AMD64
Submission from: (NULL) (

I downloaded R-2.0.1 from the R website, ran configure then make and got an
error. I will paste a copy of the output from the makefile below. The problem
was when the makefile tried to run the R binary. When I came across the error I
reran configure, but this time with the following arguments:

./configure FFLAGS="-g" CFLAGS="-g" CXXFLAGS="-g"

This time when I ran make it compiled with no problems. I tried the same thing
again only with all of the flags set to "-O" and again it compiled with no
problems. When I ran it with the flags set to "-g -O2" it had the same error. A
copy of the output from gdb can be found at
http://blackk.union.edu/~black/freebsd/R-error.txt, but the output isn't very

The system used is a laptop, Compaq Presario (amd64), under FreeBSD 5.3 compiled
for the amd64 architecture.

Output from make with flags "-O2"

black at compaqlaptop$ pwd
black at compaqlaptop$ make
echo "building package 'base'"
building package 'base'
/usr/local/bin/bash ../../../src/scripts/mkinstalldirs ../../../library/base/R
(f=${TMPDIR:-/tmp}/R$$;  cat `LC_COLLATE=C ls ./R/*.R ./R/unix/*.R` >> ${f};
/usr/local/bin/bash ../../../tools/move-if-change ${f} all.R)
all.R is unchanged
/usr/local/bin/bash ../../../tools/copy-if-change all.R
../../../library/base/R/base ${f}
../../../library/base/R/base is unchanged
for f in COPYRIGHTS INDEX SOURCES; do  if test -f ./${f}; then
/usr/bin/install -c -m 644 ./${f}  ../../../library/base;  fi;  done
if test -f DESCRIPTION; then  /usr/bin/install -c -m 644 DESCRIPTION
../../../library/base;  (tmp="Built: R 2.0.1; ";  if test -d ./src; then
tmp="${tmp}x86_64-unknown-freebsd5.3";  fi;  tmp="${tmp}; `date`; unix";  echo
"${tmp}")  >> ../../../library/base/DESCRIPTION;  fi
/usr/local/bin/bash ../../../src/scripts/mkinstalldirs
for f in `ls -d ./demo/* | sed -e '/CVS/d' -e '/00Index/d'`; do
/usr/bin/install -c -m 644 ${f} ../../../library/base/demo;  done
/usr/local/bin/bash ../../../src/scripts/mkinstalldirs
(f=${TMPDIR:-/tmp}/R$$;  for rdfile in ./man/*.Rd ./man/unix/*.Rd; do  echo "%
--- Source file: ${rdfile} ---";  cat ${rdfile}; echo '\eof';  done >> ${f};
/usr/local/bin/bash ../../../tools/move-if-change ${f}
rm -f ../../../library/base/man/base.Rd.gz
/usr/bin/gzip ../../../library/base/man/base.Rd
/usr/bin/install -c -m 644 ./inst/CITATION ../../../library/base
/usr/bin/install -c -m 644 all.R ../../../library/base/R/base
cat ./makebasedb.R |  R_DEFAULT_PACKAGES=NULL LC_COLLATE=C ../../../bin/R
--vanilla --slave > /dev/null
Floating point exception (core dumped)
*** Error code 136

Stop in /tmp/R-2.0.1/src/library/base.

More information about the R-devel mailing list