[Rd] Problem with compiling - Freebsd on AMD64 (PR#7489)

Peter Dalgaard p.dalgaard at biostat.ku.dk
Mon Jan 10 16:08:46 CET 2005

kjblack at gmail.com writes:

> Full_Name: Kelly Black
> Version: 2.0.1
> OS: FreeBSD 5.3 on AMD64
> Submission from: (NULL) (
> I downloaded R-2.0.1 from the R website, ran configure then make and got an
> error. I will paste a copy of the output from the makefile below. The problem
> was when the makefile tried to run the R binary. When I came across the error I
> reran configure, but this time with the following arguments:
> ./configure FFLAGS="-g" CFLAGS="-g" CXXFLAGS="-g"
> This time when I ran make it compiled with no problems. I tried the same thing
> again only with all of the flags set to "-O" and again it compiled with no
> problems. When I ran it with the flags set to "-g -O2" it had the same error. A
> copy of the output from gdb can be found at
> http://blackk.union.edu/~black/freebsd/R-error.txt, but the output isn't very
> helpful.


This sounds like a compiler error, so information about the GCC
version used is crucial. Switching compilers or running with less than
optimal optimization is your best chance, unless you can pinpoint
exactly what is getting miscompiled so that a workaround can be found. 

   O__  ---- Peter Dalgaard             Blegdamsvej 3  
  c/ /'_ --- Dept. of Biostatistics     2200 Cph. N   
 (*) \(*) -- University of Copenhagen   Denmark      Ph: (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)             FAX: (+45) 35327907

More information about the R-devel mailing list