[Rd] syntax error in memory.c when building R-devel on AIX

Prof Brian Ripley ripley at stats.ox.ac.uk
Tue Mar 15 22:11:11 CET 2005

That statement was added yesterday (not by me) and needed moving up a 
line. Which version do you have?  The current one has

 	    Rboolean success = FALSE;
 	    s = NULL; /* initialize to suppress warning */

and passes all my tests.  The previous one had those two lines reversed 
and worked on gcc (with a warning) but failed on Solaris' cc (and was not 
legal ISO C90).

On Tue, 15 Mar 2005, Liaw, Andy wrote:

> OK, this is really a new one for me.  Just thought I'd try building R-devel
> (2005-03-15) on our AIX power machines and see if there are any problems.  I
> used the settings in the Appendix B of R-admin, using the set of variables
> that Tim Hoar used (i.e., trying to build 64-bit R using native compilers).
> configure ran fine, but `gmake' gave me a syntax error when compiling
> src/main/memory.c.  The offending line seems to be:
>    Rboolean success = FALSE;
> Can anyone provide pointers?
> (Just to make sure, I tried building it on our SLES9-x86_64 box, and that
> passes make check.)

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-devel mailing list