[Rd] R-devel does not compile under FreeBSD-7.0 CURRENT [SOLVED]

Rainer Hurling Rainer.Hurling at nw-fva.de
Fri Dec 1 09:10:48 CET 2006

I tried todays R-devel (2006-11-30) with FreeBSD-7.0 CURRENT and it 
seems, that compiling with 'make && make install' is ok again.

Thank you very much,
Rainer Hurling

Prof Brian Ripley wrote:
> As I said to you privately, I believe this to be a make issue: does GNU 
> make work?  We don't guarantee R to work with other makes (although it 
> usually does).
> My guess is that the problem is the missing .m in the .SUFFIXES list
> in Makeconf.in, but Solaris make and GNU make see no problem and it 
> looks like a make bug to me.  I've added the suffix, so please try the 
> current version.
> (This seems to be related to adding ObjC support which is apparently 
> currently incomplete.)
> On Wed, 29 Nov 2006, Rainer Hurling wrote:
>> I am not able to compile R-devel 2006-11-28 under FreeBSD-7.0 CURRENT. 
>> After running ./configure script 'make' stops with the following error 
>> message:
>> --------------------------
>> #make
>> gcc -I. -I./src/include -I./src/include -I/usr/local/include
>> -DHAVE_CONFIG_H -g -O2 -c  -o .m.o
>> gcc: No input files specified
>> *** Error code 1
>> Stop in /usr/local/R-devel.
>> #
>> --------------------------
>> I attached configure messages. If wanted I can send complete 
>> config.log (460 kByte).
>> Are their any ideas about what is going wrong? If I could help with 
>> more information or with testing, please let me know.

More information about the R-devel mailing list