[Rd] [R] readline detection problems

Benjamin Otto b.otto at uke.uni-hamburg.de
Thu Feb 9 13:45:17 CET 2006

Dear Mr. Ripley, Mr. Leung, Mrs. Hawkins,

many thanks for the intensive help you provided me concerning the readline
problem although I should have looked in the installation manual more
thoroughly. It turned out as you already suspected that the problem with
getting the configure script detecting the new readline library could be
easily solved by setting the CFLGAS. In fact, setting the CPPFLGAS and
LDFLAGS alone results in detection of the header files but not the library

On the other hand setting the CFLAGS alone seems to be enough for the
detection of both library and header files thus solving the problem without
necessity of the previous two flags. However that seems to apply only for
the configure script. Under native conditions with the flags set the make
command fails in locating the -lreadline flag during compilation. I suppose
that should be solved with linking the library via ldconfig in a personal
local cache file. I'm working on that.

Benjamin Otto

> -----Original Message-----
> From: Hin-Tak Leung [mailto:hin-tak.leung at cimr.cam.ac.uk]
> Sent: 03 February 2006 14:34
> Cc: Benjamin Otto; r-devel at stat.math.ethz.ch
> Subject: Re: [Rd] [R] readline detection problems
> Prof Brian Ripley wrote:
> > On Fri, 3 Feb 2006, Benjamin Otto wrote:
> >
> >
> >>Dear Mr. Ripley,
> >>
> >>thanks for the quick reply. I set these flags now, however
> there still seem
> >>to be some problems with readline. The corresponding cofigure output is:
> >>
> >>checking readline/history.h usability... yes
> >>checking readline/history.h presence... yes
> >>checking for readline/history.h... yes
> >>checking readline/readline.h usability... yes
> >>checking readline/readline.h presence... yes
> >>checking for readline/readline.h... yes
> >>checking for rl_callback_read_char in -lreadline... no
> >>checking for main in -lncurses... no
> >>checking for main in -ltermcap... yes
> >>checking for rl_callback_read_char in -lreadline... no
> >>checking for history_truncate_file... no
> >>configure: error: --with-readline=yes (default) and headers/libs are not
> >>available
> >
> >
> > What does config.log say?  It looks like it is not finding
> libreadline.so.
> > You may need LD_LIBRARY_PATH set to include where it is.
> LD_LIBRARY_PATH affects the dynamic link loader, which is probably not
> the issue here. the barbaric manipulation of CFLAGS (=-I and -L)
> is needed.
> >>The existing compiler is gcc version 2.8.1 and the linker
> editor used by gcc
> >
> >
> > Wow, that is really old!
> 2.8.1 would be pre-cygnus/egcs , 1997-1998 ... should breath down the
> sys-admin's neck to get it upgraded - ncurse, termcap, tcltk, etc
> would be rather old as well...

More information about the R-devel mailing list