[Rd] compiling R-devel

apjaworski at mmm.com apjaworski at mmm.com
Fri Aug 31 22:31:28 CEST 2007


I am in a habit of compiling daily snapshots of R-devel and R-patched on my
Windows XP workstation.  I have cygwin environment with up-to-date RTools
and MiKTeX.  I run cygwin and MiKTeX upadaters pretty often (every couple
of days) so both of them are reasonably current.

Recently I noticed a small annoyance when compiling R-dvel.  It started
happening right after I updated to the new version of RTools (containing
MinGW 4.2.1-sjlj compilers).  Everything else stayed the same with possible
exception of MiKTeX update.

I usually just type "make distribution" to compile everything.  The
compilation itself goes smoothly.  Then the PDF version of the reference
manual is created.  Then I see this:

Output written on refman.pdf (1563 pages, 7869936 bytes).
Transcript written on refman.log.
creating doc/manual/version.texi
texi2dvi --pdf --texinfo="@set UseExternalXrefs " R-FAQ.texi
This is pdfTeX, Version 3.141592-1.40.4 (MiKTeX 2.6)
entering extended mode
! I can't find file `\tmp\t2d6036\xtr\R-FAQ.texi'.
<*> /tmp/t2d6036/xtr/R-FAQ.texi

Please type another input file name:

Now the file  /tmp/t2d6036/xtr/R-FAQ.texi exists at this point is not empty
and has usual protection codes.  I tried different versions of back and
front slashes, double backslashes, etc., but to no avail.  I was getting
the same message - the file cannot be found.  The only thing that works is
the plain file name.  That is, if I just type (or copy and paste) the
string R-FAQ.texi everything works fine.  This happens three times for
every manual (except the refman).  After that the compilation ends
normally, the windows installer is created and, when I run the installer, I
get everything working correctly including PDFs of the manuals.

It looks to me like the /tmp/t2d6036/xtr/ part of the name gets already
pre-pended to whatever name the make process provides so it expects just
the file name.  Alternatively, something changed in my MiKTeX setup due to
updates.  However, the refman compiles properly and I can also compile
other LaTeX with no apparent problems.

Thanks in advance,


Andy Jaworski
Process Laboratory
3M Corporate Research Laboratory
E-mail: apjaworski at mmm.com
Tel:  (651) 733-6092
Fax:  (651) 736-3122

More information about the R-devel mailing list