[Rd] Display list redraw incomplete

Deepayan Sarkar deepayan.sarkar at gmail.com
Thu May 10 21:02:39 CEST 2007

On 5/10/07, Roger Peng <rdpeng at gmail.com> wrote:
> Just to follow up with a few more details on this problem (which
> persists on my PowerBook Mac but no where else).  I ran a bisection
> search on the sources and found that SVN revision 40634 introduces
> this problem.  This revision introduced quite a few changes to
> 'src/main/graphics.c' which I am just beginning to go through.
> GIven that I don't see this problem on my Linux box and only on the
> Mac, I'm tempted to think this is a compiler issue or perhaps some
> weird problem with my setup.  I noticed that I don't have the exact
> same gfortran compiler as recommended on
> http://r.research.att.com/tools/ but I don't see how that would cause
> a problem here.
> Otherwise, I am using gcc 4.0.1 which comes with Xcode.
> I will keep digging but any pointers would be appreciated.

For the record, I saw the same behaviour a few days back on PPC Linux,
but it was only inside my experimental GUI and not with the CLI. I
assumed it was a problem with my GUI code. The "Display list redraw
incomplete" message was intermittent, but the opening of the extra
windows was fairly consistent (but they popped up and then closed).

I don't remember the exact triggering mechanism, and I don't remember
seeing it recently. I can't reproduce it on my desktop, which is i486
Linux (according to R). I'll try the ppc when I get home.


> Thanks,
> -roger
> On 5/4/07, Roger Peng <rdpeng at gmail.com> wrote:
> > Since compiling R 2.5.0 from source on my Mac (PowerBook) I've noticed
> > some strange behavior when plotting.  I'm not sure if it's a problem
> > with my setup/compilation because I feel like a problem as basic as
> > this one would have been reported already.  I'm running R with X11 and
> > R was built with gcc 4.0.1.
> >
> > Basically, I run
> >
> > > plot(0, 0)
> > > dev.off()
> > X11
> >   4
> > Warning message:
> > Display list redraw incomplete
> >
> > I don't think I've ever seen that warning before.  In addition to the
> > warning, two extra x11 devices are launched.  Same thing happens in
> > R-devel (r41438).  Any thoughts on what might be going on?
> >
> > Thanks,
> > -roger
> > --
> > Roger D. Peng  |  http://www.biostat.jhsph.edu/~rpeng/
> >
> --
> Roger D. Peng  |  http://www.biostat.jhsph.edu/~rpeng/
> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list