[Rd] Building package with R 2.6.0 on Windows/Cygwin gives error with tar

Prof Brian Ripley ripley at stats.ox.ac.uk
Fri Oct 5 14:19:01 CEST 2007

Try setting TAR to 'tar --force-local'.

This should be the default under Windows, but a typo was introduced in R 
2.6.0 after it was tested.

On Thu, 4 Oct 2007, Kevin Wright wrote:

> My setup:
> Windows XP, R-2.6.0, Cygwin (not the Rtools version)
> When I tried to build a package, I was given this message:
> tar: c\:/X/Rpkgs/Drydown_1.41.tar: Cannot open: Input/Output error
> Even manually typing the following caused the same error:
> tar chf 'c:/X/Rpkgs/Drydown_1.41.tar' Drydown
> I looked at the 2.5.1 and 2.6.0 build scripts.  After restoring this
> section to the 2.6.0 build script:
>  ## workaround for paths in Cygwin tar
>  $filepath =~ s+^([A-Za-z]):+/cygdrive/\1+;
>  }
> then $filepath evaluates to
>  /cygdrive/c/X/Rpkgs/Drydown_1.41.tar
> and I was able to build packages again.
> (Posted in case someone else has the same problem and/or finds this useful.)

It WOULD have been useful if you had tested in the alpha/beta/RC period 
and not immediately after release.  (I believe this has been asked of you 

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-devel mailing list