[Rd] Outdated dependencies and install.packages()

Peter Dalgaard P.Dalgaard at biostat.ku.dk
Wed Aug 20 12:30:19 CEST 2008

This looks like a buglet:

> install.packages("lme4", depend=TRUE, lib="~/Rlibrary/")
--- Please select a CRAN mirror for use in this session ---
** preparing package for lazy loading
Error: package 'Matrix' 0.999375-4 was found, but >= 0.999375.11 is
required by 'lme4'
Execution halted
ERROR: lazy loading failed for package 'lme4'
** Removing '/home/bs/pd/Rlibrary/lme4'
** Restoring previous '/home/bs/pd/Rlibrary/lme4'

and the DESCRIPTION file for lme 4 does have

Depends: methods, R(≥ 2.7.0), Matrix(≥ 0.999375-11), lattice

Looks like we're either not checking the version requirement of
dependencies, or something is making 4 > 11... (from my reading of the
code, it is the former, but I could have missed something).

We should at least document the behaviour.

   O__  ---- Peter Dalgaard             Øster Farimagsgade 5, Entr.B
  c/ /'_ --- Dept. of Biostatistics     PO Box 2099, 1014 Cph. K
 (*) \(*) -- University of Copenhagen   Denmark      Ph:  (+45) 35327918
~~~~~~~~~~ - (p.dalgaard at biostat.ku.dk)              FAX: (+45) 35327907

More information about the R-devel mailing list