[Rd] Vignette pdfs missing from zip file after Rcmd build --binary call

Eli Holmes e2holmes at gmail.com
Thu Jul 7 09:39:09 CEST 2011


I have been building R packages for awhile on Windows, and I recently
upgraded R and all required package creation tools to 2.13.0.  I
understand that there have been changes in that the R CMD build
command no longer alters the source directory, cf comments in
For example, if I issue the command Rcmd build FOO, then directory FOO
is not altered in contrast to earlier R versions where vignette pdfs
would be added to the source directory FOO.

I have no problem creating the FOO.tar.gz file, and it has the
vignette pdfs in the inst/doc as usual.   The problem is the .zip file
that I create for Windows users.  In earlier versions of R, this .zip
file had the newly created vignette pdfs but now it does not.  Here is
what I see:

source FOO:

FOO.tar.gz   (after Rcmd build FOO)

FOO.zip (after Rcmd build --binary FOO or R CMD install --build FOO)

Yes, I can manually move the pdf files from the tar.gz directory to
the zip directory, but there are many and I am liable to make

I suppose I could unzip the tar.gz file and then make a temporary
source file FOOtmp and run Rcmd build --binary FOOtmp, but I am hoping
there is an easier way.

Things I have tried unsuccessful
 I tried using the tar.gz file as the source
Rcmd build --binary FOO.tar.gz   (got error)
R CMD install --build FOO.tar.gz (same error)

I tried using some of the options for R CMD install:
--force-multiarch  and --merge-multiarch.  No change.

Any ideas?


More information about the R-devel mailing list