[Rd] Can't install.packages() from local repo in 2.15.2

Imanuel Costigan i.costigan at me.com
Fri Nov 2 10:28:01 CET 2012

Hi guys  

I think there's a high chance this is a bug. But I can't rule out that I can be blamed for this. I've posted this to bugzilla (#15092). Then I read that I probably should have posted it to R-develop first. Sorry for doing this in the wrong order.

I've set up a local repo on my local drive (happens to be mapped to L:/). It has the following structure (as per http://cran.r-project.org/doc/manuals/R-admin.html#Setting-up-a-package-repository):  


I created a bare bones package (`anRpackage`) using `package.skeleton`. I cleaned it up and added a basic function, checked it and built it from command line using `R CMD INSTALL --build .`. That generates `anRpackage_1.0.zip` with no errors. Note:

$ R CMD INSTALL --build --version  
R add-on package installer: 2.15.2 (r61015)  

I have Rtools 2.16 installed (as this is for R >2.15.1 to R 2.16.x). I have also followed the instructions here: http://cran.r-project.org/doc/manuals/R-admin.html#The-Windows-toolset

I copy that to L:/R/bin/windows/contrib/2.15 (for example), run `tools::write_PACKAGES()` in that directory. That successfully generates the packages file. I also run `tools::write_PACKAGES()` in L:/R/src/contrib to generate an empty PACKAGES file.  

I have the following in my .Rprofile (among other things):  

.First <- function ()  
   options( repos = c(CRAN = "http://cran.csiro.au/",  
                               LREPO = "file:///L:/R/"))  

I run `install.packages("anRpackage") and I get the following error:  

Installing package(s) into ‘C:/Program Files/R/R-2.15.2/library’  
(as ‘lib’ is unspecified)  
Warning in install.packages : package ‘anRpackage’ is not available (for R version 2.15.2)  

Same issue on another Windows machine.

However, if I run `install.packages("L:/R/bin/windows/contrib/2.15/anRpackage_1.0.zip", repos=NULL)`, it installs successfully.  

I do not have this problem in R 2.15.1.

NB: If I provide full file path to install.packages and set repos=NULL, and then check the package's DESCRIPTION file in the help, I see this at the bottom:  

`Built: R 2.15.2; ; 2012-11-01 00:22:07 UTC; windows`  

(when I've built package using 2.15.2 obviously)


More information about the R-devel mailing list