[Rd] Problems with install.packages when Ncpus > 1

Winston Chang winstonchang1 at gmail.com
Sat Oct 6 06:42:37 CEST 2012

I have a Ubuntu Linux 12.04.1 machine running R 2.15.1. I'm trying to
run tests building packages, so install.packages() is trying to
install about about 1000 packages from source. I'm running into some
strange issues that seem related to using values for Ncpus other than 1.

When I use Ncpus=32, about 260 of the packages fail to install. When I
tried again with Ncpus=2, more of them get installed, and there were
only 234 failed packages. I tried it again with Ncpus=1, after which
there were only 142 failed packages. (I think these remaining failed
packages are due to missing external dependencies, like RODBC, Java,
and various development libraries, so these aren't a concern at the

In the code for install.packages, I see that if Ncpus>1, it passes the
Ncpus to make, as in 'make -k -j 32'. Is it possible that these
packages are failing because of this option to make?

Has anyone else run into this issue before?


More information about the R-devel mailing list