[Rd] configure.ac

Ramón Fallon ramonfallon at gmail.com
Tue Aug 1 17:29:20 CEST 2017


Just a quick mail to mention that I cannot generate a new configure script
using autoconf or autoreconf. I had edited the configure.ac and thought ...
"oh, that's my fault", but then I tried it on R-patched and R-3.4.1 without
touching configure.ac and had the same problems.

The "building R packages" documentation seems to suggest that "autoconf"
should take care of it, but I must be missing something as I expect it to
be a common task.

I also tried explicit autohell (yes, I know) commands
1) autoreconf --force -v
completes but invoking configure (with no options) gives

checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
loading site script './config.site'
loading build-specific script './config.site'
./configure: line 2982: syntax error near unexpected token `blas'
./configure: line 2982: `  withval=$with_blas; R_ARG_USE(blas)'

OK.. there's a recipe that oen can use, starting with:

libtoolize --force

but you get:

A sequence typical found out there, starting withlibtoolize: putting
auxiliary files in AC_CONFIG_AUX_DIR, `tools'.
libtoolize: linking file `tools/ltmain.sh'
libtoolize: You should add the contents of the following files to
libtoolize:   `/usr/share/aclocal/libtool.m4'
libtoolize:   `/usr/share/aclocal/ltoptions.m4'
libtoolize:   `/usr/share/aclocal/ltversion.m4'
libtoolize:   `/usr/share/aclocal/ltsugar.m4'
libtoolize:   `/usr/share/aclocal/lt~obsolete.m4'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.ac and
libtoolize: rerunning libtoolize, to keep the correct libtool macros
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.


automake --force-missing --add-missing

first two go OK, but the third gives

configure.ac: no proper invocation of
 was found.
configure.ac: You should verify that configure.ac invokes AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using aclocal).
automake: no `Makefile.am' found for any configure output

then the following runs OK

but running configure gives the same BLAS error.

But I'm farily sure one shouldn't run to see what's wrong with BLAS,ratehr
it's just the configure options not being read properly. The
issue definitely seems important.

Is there anything I'm missing?

Cheers and thanks in advance!

	[[alternative HTML version deleted]]

More information about the R-devel mailing list