[Rd] . Possible issue with R-tools on Windows

Georgi Boshnakov georgi.boshnakov at manchester.ac.uk
Sun Mar 12 16:58:09 CET 2017

I encountered this issue a couple of months ago and resolved it by installing Rtools in the default directory
C:\Rtools, see below for details. I didn't have time to prepare a proper error report and in fact suspected that I may be messing up something.

I tracked down the error by installing from the command line, rather than with install.packages().

On Windows I keep multiple versions of Rtools  (and R) 
and start a command window with a batch file which has something like the following at its start: 

set Rroot=c:\ProgramF\R\R-3.3.2patched
set RtoolsRoot=c:\PROGRAMF\R\Rtools3p3

To change the R version I simply copy the file and change the above two lines correspondingly.
This worked for years until recently when

> R CMD INSTALL Countr_3.2.8.tar.gz

Produced an error:

c:/Rtools/mingw_32/bin/g++: not found

(notice that the installer looks in c:/Rtools for g++)

I knew and checked again that the path to Rtools was passed correctly.
I dealt with this by installing Rtools in c:\Rtools and changing the above line in the batch file to:

REM was: set RtoolsRoot=c:\PROGRAMF\R\Rtools3p3
set RtoolsRoot=c:\Rtools

and everything worked.

Hope this helps.

Best regards,
Georgi Boshnakov

-----Original Message-----

Date: Sat, 11 Mar 2017 11:17:15 -0600
From: Robert Baer <rbaer at atsu.edu>
To: "'r-devel at r-project.org'" <r-devel at r-project.org>
Subject: [Rd] Possible issue with R-tools on Windows
Message-ID: <a0736ca8-0665-4067-e337-6489f55b8fcc at atsu.edu>
Content-Type: text/plain; charset=utf-8; format=flowed

This is a bit of a cross-post but I've encountered what appears to be a parsing error with RTools on Windows in a couple of different contexts on Widows when R is installed on a secondary drive to avoid using precious space on my c:/ solid state drive.

This type of apparent parsing error has has occurred several times previously when install source code from GitHub, and most recently when installing Bioconductor code.  It occurred that this list might have input directed at RTools on Windows, if this is indeed my problem

Here's the full example of my most recent encounter posted to
bioconductor: https://support.bioconductor.org/p/93731/

In brief the parsing seems to break in the space in the path name:

The downloaded source packages are in
     ?C:\Users\Rob Baer\AppData\Local\Temp\RtmpagJM0a\downloaded_packages?
Warning messages:
1: running command '"E:/Program Files/R/R-3.3.3/bin/x64/R" CMD INSTALL -l "C:\Users\Rob Baer\R\win-library\3.3" 
had status 1
2: In install.packages(update[instlib == l, "Package"], l, repos = repos,  :
   installation of package ?GO.db? had non-zero exit status

Is there something going on with my RTools installation I should upgrade?  My apologies if this is too off-topic for this list.


Subject: Digest Footer

R-devel at r-project.org mailing list  DIGESTED


End of R-devel Digest, Vol 169, Issue 12

More information about the R-devel mailing list