[Rd] undefined symbol: cholmod_factorize_p (solved)

Göran Broström gor@n@bro@trom @ending from umu@@e
Sat Jul 7 14:25:01 CEST 2018

On 2018-07-07 13:41, Göran Broström wrote:
> On 2018-07-07 13:08, Jeroen Ooms wrote:
>> On Fri, Jul 6, 2018 at 11:57 PM, Göran Broström
>> <goran.brostrom using umu.se> wrote:
>>> I am installing R_3.5.1 from source on ubuntu 18.04, and 'config' +
>>> 'make' gives me (at the end)
>> Probably something went wrong earlier in the build when compiling
>> the Matrix package. However it's much easier to install R form the 
>> binaries:
>> sudo add-apt-repository -y ppa:marutter/rrutter3.5 sudo apt-get
>> update sudo apt-get install r-base
> Thanks, after a discussion with Dirk on r-sig-debian I did just that.
> The reason I compiled R from source was that I had some problems with 
> the binary install but without the ppa:marutter. With it everything works.
>> If you really want to build from source, have a look at which flags 
>> and dependencies are used in the r-base source package on Debian/Ubuntu.
> I certainly will be able to do that (it has "always" worked seamlessly 
> for me, don't understand what happened this time. Maybe the upgrade to 
> 18.04), so I will have a look.

I had a look in ~/.R and there I found a file 'Makevars' containing:


Removing it removed the problem! Its existence was a result of a 
discussion on r-pkg-devel, which I now will take up again (but after the 


> Many thanks, Göran
> ______________________________________________
> R-devel using r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list