[Rd] Underscores in package names

Jim Hester j@me@@|@he@ter @end|ng |rom gm@||@com
Thu Aug 15 15:00:01 CEST 2019


Thank you for discussing this amongst R-core and for detailing the
R-core discussion here.

Some specific examples where having underscores available would have
been useful.

1. My primerTree package (2013) was originally primer_tree, but I had
to change the name to camelCase to comply with the check requirements.
Using camelCase in the package name makes reading code jarring, as the
functions all use snake_case.
2. The widely used testthat package would likely be called test_that,
like the corresponding function within the package. This also
highlights one of the drawbacks of the current situation, without
separators the package name is more difficult to read, does it have
two t's or three?
3. The assertive suite of packages use `.` for separation, e.g.
`assertive.base`, `assertive.datetimes` etc. but all functions within
the packages use `_` separators, again likely this was done out of
necessity rather than desire.

There are many more I am sure, these were some that came immediately
to mind. More important than the specific examples is the opportunity
cost of having this restriction, which we cannot really quantify.

Using dots for separators has a number of practical problems.
Functions using dots are ambiguous, e.g. is `as.data.frame()` a
regular function, an `as.data()` method for a `frame` object, or an
`as()` method for a `data.frame` object? And in fact regular functions
can be accidentally promoted to S3 methods by defining a S3 generic,
which does actually happen in real life, confusing users [1]. While
package names are not functions, using dots in package names
encourages the use of dots in functions, a dangerous practice. Dots in
names is also one of the common stones cast at R as a language, as
dots are used for object oriented method dispatch in other common

The prevalence of dotted functions is the only major naming convention
which is steadily decreasing over time. It now accounts for only
around 15% of all function names when looking at all 94 Million lines
of code currently available on CRAN (See Figure 2. from Yen et. al.

Thanks again for the public discussion,


[1]: https://twitter.com/_ColinFay/status/1105579764797108230
[2]: https://osf.io/preprints/socarxiv/ts2wq/

On Wed, Aug 14, 2019 at 5:16 AM Martin Maechler
<maechler using stat.math.ethz.ch> wrote:
> >>>>> Duncan Murdoch
> >>>>>     on Fri, 9 Aug 2019 20:23:28 -0400 writes:
>     > On 09/08/2019 4:37 p.m., Gabriel Becker wrote:
>     >> Duncan,
>     >>
>     >>
>     >> On Fri, Aug 9, 2019 at 1:17 PM Duncan Murdoch <murdoch.duncan using gmail.com
>     >> <mailto:murdoch.duncan using gmail.com>> wrote:
>     >>
>     >> On 09/08/2019 2:41 p.m., Gabriel Becker wrote:
>     >> > Note that this proposal would make mypackage_2.3.1 a valid
>     >> *package name*,
>     >> > whose corresponding tarball name might be mypackage_2.3.1_2.3.2
>     >> after a
>     >> > patch. Yes its a silly example, but why allow that kind of ambiguity?
>     >> >
>     >> CRAN already has a package named "FuzzyNumbers.Ext.2", whose tarball is
>     >> FuzzyNumbers.Ext.2_3.2.tar.gz, so I think we've already lost that game.
>     >>
>     >>
>     >> I suppose technically 2 is a valid version number for a package (?) so I
>     >> suppose you have me there. But as Ben pointed out while I was writing
>     >> this, all I can really say is that in practice they read to me (as
>     >> someone who has administered R on a large cluster and written
>     >> build-system software for it) as substantially different levels of
>     >> ambiguity. I do acknowledge, as Ben does, that yes a more complex
>     >> regular expression/splitting algorithm can be written that would handle
>     >> the more general package names. I just don't personally see a motivation
>     >> that justifies changing something this fundamental (even if it is both
>     >> narrow and was initially more or less arbitrarily chosen) about R at
>     >> this late date.
>     >>
>     >> I guess at the end of the day, I guess what I'm saying is that breaking
>     >> and changing things is sometimes good, but if we're going to rock the
>     >> boat personally I'd want to do so going after bigger wins than this one.
>     >> Thats just my opinion though.
>     > Sorry, I wasn't clear.  I agree with you.  I was just saying that the
>     > particular argument based on ugly tarball names isn't the reason.
>     > Duncan Murdoch
> Thank you (and Gabe).
> We have had some R core internal "talk" about Jim Hester's
> suggestion (of adding underscores to the allow characters in
> package names).
> Duncan had already given a good reason why such a change would be problematic
> (the underscore being used as unique separator of package name
>  and version in source and binary package archives),
> and with Jim's offer to find and provide patches for all places
> this is used in the R sources, we've convinced ourselves that
> there is much more code "out there", notably 'devops' code in
> scripts, which currently relies on the current package naming
> rules and which could break, often only rarely and hence
> possibly unnoticed for too long.
> Also, we've not seen compelling arguments why the current scheme
> would be too limited (people mentioned that if you must use a
> separator, "." was available).
> Consequence:  We stay with the stability principle and the
> package naming scheme is _not_ going to be changed for now.
> Martin Maechler
> ETH Zurich and R Core Team

More information about the R-devel mailing list