[Rd] status of Java & rJava?

Spencer Graves @pencer@gr@ve@ @end|ng |rom prod@y@e@com
Sun Mar 29 07:58:39 CEST 2020

On 2020-03-28 23:07, Prof Brian Ripley wrote:
> On 29/03/2020 04:07, Simon Urbanek wrote:
>> Spencer,
>> you could argue that Java is dead since Oracle effectively killed it 
>> by removing all public downloads, but if you manage to get hold of a 
>> Java installation then it works just fine with R. To my best 
>> knowledge there has never been an issue if you installed rJava from 
>> source. macOS Catalina has made binary distributions impossible due 
>> to additional restrictions on run-time, but even that has been how 
>> solved with the release of rJava 0.9-12, so please make sure you use 
>> the latest rJava. In most cases that I have seen issues were caused 
>> by incorrect configuration (setting JAVA_HOME incorrectly [do NOT set 
>> it unless you know what you're doing!], not installing Java for the 
>> same architecture as R etc.). If you have any issues feel free to 
>> report them. rJava 0.9-12 has quite a few changes that try to detect 
>> user errors better and report them so I strongly suggest users to 
>> upgrade.
> There is OpenJDK, and https://adoptopenjdk.net provides binaries for 
> macOS, including the preferred Java 11 LTS.  I just re-checked that, 
> and after
> env 
> JAVA_HOME=/Library/Java/JavaVirtualMachines/adoptopenjdk-11.jdk/Contents/Home 
> R CMD javareconf
> I was able to install from source and check rJava 0.9-12 in 4.0.0 
> alpha.  For the CRAN binary of 3.6.3 I had to make sure I was using 
> clang 7: 'clang' defaults to that in the Apple CLT which does not 
> support -fopenmp -- but the binary package just worked.
> [All on Catalina.]

Thanks.  That worked on Catalina.  When installing OpenJDK on Windows 
10, The default for "Set JAVA_HOME" was 'X';  I changed that to 
install.  It didn't work at first, but did after I rebooted.

Thanks again to both Simon Urbanek and Prof. Ripley.  Spencer Graves

More information about the R-devel mailing list