[R] atlas for R1.1.1 and R1.2 different?

Marcus Eger marcus.eger at physik.uni-marburg.de
Tue Nov 14 15:35:17 CET 2000

Bingo, before I tried to install R1.2.0 I installed integrate2.2.2 which
indeed needed atlas2-dev. R1.1.1 went smoothly, and also did R1.2.0,
until I reinstalled integrate2.2.2 which - I did not know - was
already shipped with R1.2.0.


ps. to Peter Daalgard:  I installed R1.2.0 and R1.1.1 in different
and even removed the old installation before doing a make install again...

Kurt Hornik wrote:

> I suspect that your R 1.1.1 is from a .deb file which requires package
> atlas2, and the R 1.2.0 is compiled from source but cannot find atlas
> (look at config.log) because package atlas2-dev is not installed.
> Bingo?

Peter Dalgaard BSA wrote:

> Marcus Eger <marcus.eger at physik.uni-marburg.de> writes:
> > I guess I know where the problem comes from...
> > I reinstalled integrate2.2.2 not knowing that integrate was already
> > contained in R1.2.0. Doing a make install of R1.2.0 solved the problem.
> Er? It isn't...
> I did install.packages('integrate') from inside R. However, if you
> were loading an older .so file, which was linked against atlas into an
> R which wasn't, you might get into trouble.... Conversely, make
> install may cause you to install R on top of your old R 1.1 and get
> you your *previous* integrate.so. So I'd try reinstalling the
> integrate package before claiming success!

| Marcus Eger
| E-Mail: eger.m at gmx.de (NEW)
|         marcus.eger at physik.uni-marburg.de (OLD)
| WWW:    http://neuro.physik.uni-marburg.de/~eger (NEW)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://stat.ethz.ch/pipermail/r-help/attachments/20001114/da7c57df/attachment.html

More information about the R-help mailing list