[R] Re: R installation with tcltk

Naoki Saito saito at math.ucdavis.edu
Wed Apr 18 22:28:22 CEST 2001


Thanks to the help from Prof. Ripley, I can now run R under my Solaris 2.6
machine!  I should have include the correct library path in

However, I still get the following problem.
I configured the R system with --with-tcltk option.
In fact, I ran the following:

/configure --prefix=/opt/local --with-f77 --with-tcltk --with-tcl-config=/opt/local/lib/tclConfig.sh --with-tk-config=/opt/local/lib/tkConfig.sh

My local libraries are all in /opt/local/lib area.
Everything was compiled normally without error and I got R and R.bin execs.
Now, I have the following error even I put the correct library path.

> demo('tkttest')

        ---- ~~~~~~~

Type  <Return>   to start : 

> require(tcltk) || stop("tcltk support is absent")
Loading required package: tcltk 
Error in dyn.load(x, as.logical(local), as.logical(now)) : 
        unable to load shared library "/opt/pkg/R-1.2.2/library/tcltk/libs/tcltk.so":
  ld.so.1: /opt/pkg/R-1.2.2/bin/R.bin: fatal: relocation error: file /opt/pkg/R-1.2.2/library/tcltk/libs/tcltk.so: symbol Tcl_Alloc: referenced symbol not found
Error in .C("delTcl", PACKAGE = "tcltk") : 
        C/Fortran function name not in load table
Error in eval.with.vis(expr, envir, enclos) : 
        tcltk support is absent

I would appreciate it if you could help me correct this behavior.
Best regards,
Naoki Saito

 Naoki Saito, Ph.D., Associate Professor, Department of Mathematics
 University of California, One Shields Avenue, Davis, CA 95616-8633 USA
 Home Page: http://math.ucdavis.edu/~saito/
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list