[R] RJava lib error

Vahid Pazirandeh vpaziran at yahoo.com
Wed Jun 20 01:33:45 CEST 2001

Hello all!

I recently install R-1.2.3 and Omegahat SJava pkg
(formely Java pkg) 0.62 and tried running the examples
by issuing "scripts/RJava --example --gui=none" and I
got the following:

Error in dyn.load(x, as.logical(local),
as.logical(now)) : 
        unable to load shared library
fatal: relocation error: file
/usr/lib/R/library/ctest/libs/ctest.so: symbol MAIN__:
referenced symbol not found
SIGSEGV   11*  segmentation violation

I've been trying to figure this problem out for a
while, but I haven't had any luck yet.  This occurs
for any R-Java program I run.. i install it onto two
different machines and they both yielded the same

1) 5.8 Generic sun4u sparc SUNW,Ultra-5_10
2) 5.7 Generic_106541-12 sun4u sparc SUNW,Ultra-2

Any assistance would be much appreciated.. I am truely
a newbie!  

Please replyto: vpaziran at yahoo.com


< Education Center on Computational Science and Engineering >
< http://edcenter.sdsu.edu >

Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail
r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list