[R] Trouble compiling R-1.3.0 under Tru64

Kjetil Kjernsmo kjetil.kjernsmo at astro.uio.no
Mon Jun 25 20:10:28 CEST 2001

Dear all,

I have some difficulty getting R-1.3.0 to run on the alpha, with osf4.0e
(Tru64, or whatever they call it... :-) ).

configure reports the following configuration:
R is now configured for alphaev6-dec-osf4.0e

  Source directory:          .
  Installation directory:    /astro/local
  C compiler:                gcc  -mieee -g -O2
  C++ compiler:              c++  -g -O2
  FORTRAN compiler:          f77  -fpe3 -g

  X11 support:               yes
  Gnome support:             no
  Tcl/Tk support:            no

  R profiling support:       yes
  R as a shared library:     no

configure: warning: you cannot build info versions of the R manuals

The compilation seems to run smoothly for a while, but stops with when
building ctest:
Make: Cannot open ../../../../share/make/../../../../etc/Makeconf.  Stop.
It seems to be looking in the wrong place. I'm allready on thin ice, but I
tried to set R_HOME to the source directory, which is
/mn/alnair/u1/kjetikj/src/R-1.3.0/ It didn't work, but then I edited
share/make/shlib.mk to say
include /mn/alnair/u1/kjetikj/src/R-1.3.0/etc/Makeconf
and that seemed to work, the make was completed. I guess I might have done
something entirely wrong here, though, that may be the cause of the
subsequent crash.

Then I do make check, and while many tests are successful, they aren't
creating `no-segfault.R'
running `no-segfault.R'
sh: 22380 Floating exception
*** Exit 136
*** Exit 1
*** Exit 1
*** Exit 1

Help will be greatly appreciated!

BTW, before I did all this, I also tried to build R using cc as C compiler
with some optimization options. Last year, I had problems with cc and R,
as reported in (if I remember correctly) PR#551. I figured I might give it
another try, especially given the new garbage collector in 1.2.0. I failed
to reproduce the problem I had back then, something that may be a good
sign, to this build also didn't pass make check. Between the builds, I
cleared everything by removing source directory and re-extracting from


Kjetil Kjernsmo
Graduate astronomy-student                    Problems worthy of attack
University of Oslo, Norway            Prove their worth by hitting back
E-mail: kjetikj at astro.uio.no                                - Piet Hein
Homepage <URL:http://www.astro.uio.no/~kjetikj/>
Webmaster at skepsis.no

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list