[R] Compiling 1.3.1 under RH Linux

apjaworski@mmm.com apjaworski at mmm.com
Fri Sep 7 18:47:17 CEST 2001

Thanks to everyone who responded to my e-mail.

First of all the RH-7.2 was a typo - I am running 7.1.

The whole story turned out to be quite different from what I expected.  I
share it here because it might be helpful for somebody in a similar

I tried to compile R-1.3.1 with the (fixed) RH gcc compiler (version
2.96.85).  It did not get far.  In fact, if I remember correctly, the
compilation stopped at  the third file (binning.c in src/appl) with an
unspecified "internal gcc error".  That was odd, because I had no problem
compiling R-1.3.0 a few months ago.  However, since the RH gcc has been
updated since then, I decided to try kgcc which is supposed to be more
stable.  As I noticed below, the compile worked, but the tests did not.

The problem turned out to be unrelated to R or gcc.  I like dabbing in
network security issues.  Since my machine is on 24 hours a day, I run a
pretty tight firewall and frequently try different other anti-hacking
measures.  A few weeks ago I installed a loadable kernel module called
StJude.  It is supposed to stop both local and remote root exploits by
stopping "improper privilege transitions" according the StJude model.  It
turned out that the module was messing gcc up.  I unloaded the module and
the compilation of R went without a hitch and all the tests passed with no

Thanks again,


Andy Jaworski
Engineering Systems Technology Center
3M Center, 518-1-01
St. Paul, MN 55144-1000
E-mail: apjaworski at mmm.com
Tel:  (651) 733-6092
Fax:  (651) 736-3122

                    Martyn Plummer                                                                                                             
                    <plummer at iarc.f      To:     Peter Dalgaard BSA <p.dalgaard at biostat.ku.dk>                                                 
                    r>                   cc:     r-help at stat.math.ethz.ch                                                                      
                                           Andrzej P. Jaworski/US-Corporate/3M/US at 3M-Corporate                                                 
                    09/07/2001           Subject:     Re: [R] Compiling 1.3.1 under RH Linux                                                   
                    03:41 AM                                                                                                                   

On 06-Sep-2001 Peter Dalgaard BSA wrote:
> apjaworski at mmm.com writes:
>> Hi,
>> I am trying to compile R-1.3.1 under RH-7.2 Linux.  I used the old gcc
>> compiler (kgcc) and the compilation went fine.  I can start R and run
>> rudimentary tasks with no problem.  However, when I did
>>      make check
>> I got the following error in base-Ex.Rout
>>      > fa <- file.access(dir("."))
>>      Error in file.access(dir(".")) : file.access is not implemented on
>> this system
>> Any help will be appreciated.
>> Andy
> Um, isn't 7.2 still in beta? But why use kgcc, the ordinary gcc worked
> ok with 7.1.

kgcc also works with 7.1, but I'm not sure why you would want to use it.
Although the version of gcc (2.96) that shipped with Red Hat 7.0 was
horribly broken, it has been fixed.

You can install an RPM for R-1.3.1 which is available on CRAN.  This was
compiled on 7.1, but since Red Hat are supposed to maintain binary
compatibility across point releases, it should install on 7.2.


r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list