[R] R Installation problem: 'make check' errors

Fritz Roth froth at hms.harvard.edu
Sun Sep 16 19:14:46 CEST 2001

Hi All,

OK...  so it looks like '--enable-shlib' option wasn't the problem, as I've 
now done:
'make distclean'
'configure'  [no options selected]
'make check'

and I get the same error on 'make check':
../../bin/R --vanilla < base-Ex.R > base-Ex.Rout
make[4]: *** [base-Ex.Rout] Error 139

following your advice, I did
'../../bin/R -d gdb'
'r --vanilla < base-Ex.R > base-Ex.Rout'
with the following results:


[froth at lama R-1.3.1]$ cd tests/Examples/
[froth at lama Examples]$ ls
Makedeps  Makefile.in  base-Ex.R     base-Examples.ps
Makefile  all.Rdata    base-Ex.Rout
[froth at lama Examples]$ ../../bin/R -d gdb
GNU gdb 19991004
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) r --vanilla < base-Ex.R > base-Ex.Rout
Starting program: /home1/froth/R/src/R-1.3.1/bin/R.bin --vanilla < 
base-Ex.R > base-Ex.Rout
BUG IN DYNAMIC LINKER ld.so: ../sysdeps/i386/dl-machine.h: 380: 
elf_machine_rel: Assertion `! "unexpected dynamic reloc type"' failed!

Program exited with code 0177.


after running 'make check' again to proceed further to the next error:

../../bin/R --vanilla < mva-Ex.R > mva-Ex.Rout
make[4]: *** [mva-Ex.Rout] Error 139

  I also tried running mva-Ex.R within gdb:

(gdb) r --vanilla < mva-Ex.R > mva-Ex.Rout
Starting program: /home1/froth/R/src/R-1.3.1/bin/R.bin --vanilla < 
mva-Ex.R > mva-Ex.Rout

Program received signal SIGSEGV, Segmentation fault.
strcmp (p1=0x522e73 <Address 0x522e73 out of bounds>, p2=0x40010c27 "")
     at ../sysdeps/generic/strcmp.c:38
38      ../sysdeps/generic/strcmp.c: No such file or directory.
unless anyone can suggest a simpler fix to these problems, I'll assume that 
RedHat Linux 6.2 is at fault as suggested earlier and try R installation 
again after an OS upgrade  (planned in the very near future anyway)

Thanks for your advice!

Frederick P. Roth, Asst. Professor
Harvard Medical School
Dept. of Biological Chemistry and Molecular Pharmacology
250 Longwood Avenue, SGMB-322, Boston, MA 02115
(617) 432-3551 phone            (617) 432-3557 FAX
froth at hms.harvard.edu           http://llama.med.harvard.edu

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list