[R] Using RSPerl with add-on package ctest and named parameters

Frank Gibbons fgibbons at hms.harvard.edu
Thu Jun 13 17:54:21 CEST 2002

At 11:41 AM 6/13/2002, you wrote:

> > The problem is, it doesn't complain, it doesn't return anything at all.
> > Shouldn't it print out the results just like the R code does, or does it
>It would if you called print() on the return value (which is not a


I tried that already, and get the same result as if I had tried assigning 
to a scalar (see below).

Can you suggest something else? Do you know for sure that it should return 
a value (rather than printing out its own results)? If so, is there 
possibly a problem with my installation of R.so, the library mentioned in 
the error message, which is apparently unable to find the symbol to convert 
the result (whatever it is) to Perl?

Thanks for your help,


> > return them in an array? I tried catching the return value, by assigning to
> > a scalar, but get an error:
> >
> > /usr/bin/perl: relocation error:
> > /usr/lib/R/library/RSPerl/share/local/lib/perl/5.6.1/auto/R/R.so: undefined
> > symbol: userLevelConversionToPerl

PhD, Computational Biologist,
Harvard Medical School BCMP/SGM-322, 250 Longwood Ave, Boston MA 02115, USA.
Tel: 617-432-3555       Fax: 
617-432-3557       http://llama.med.harvard.edu/~fgibbons

r-help mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-help-request at stat.math.ethz.ch

More information about the R-help mailing list