[R] install.packages (newbie?) error

Prof Brian Ripley ripley at stats.ox.ac.uk
Mon Aug 4 11:32:33 CEST 2003

If you are using the Carbon version of R (there are *two* ports for MacOS 
X) then install.packages() is not included.  (Where have you been reading 
about it: under documentation for a different port?)

You need to get akima.sit from the /bin/macos/contrib area on CRAN.

On Sat, 2 Aug 2003, Åsa Byström wrote:

> I recently installed R 1.7.1 on Mac OS 10.2.6, and I now need to 
> install the akima package. When I use install.packages(akima) or any 
> variation of that command, I get the following message:
> Error: couldn't find function "install.packages"
> (I haven't had any problems with other commands so far, so I don't 
> think there's a problem with the R installation. I also threw the whole 
> thing out and re-installed R from scratch, but that didn't help.)
> I then tried simply downloading, unstuffing, and dragging the package

What do you mean by `the package'?  The sources, akima*.tar.gz or the 
MacOS binary akima.sit?
> to my library folder. But then, when I tried library(akima), another 
> error message said the package wasn't properly installed.

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-help mailing list