[R] nlme on Windows 2000 (v1.8.1)

Kent Holsinger kent at darwin.eeb.uconn.edu
Thu Apr 8 14:03:56 CEST 2004

I have a problem with nlme on Windows 2000, and I'm having a devil of a 
time determining whether the problem is with my computer or with 
something in R. I'm running v1.8.1 on a Dell Pentium III with 512MB of 
RAM and all of the recommended Windows 2000 updates applied.

If I use Rterm, I can run analyses with NLME to my heart's content. But 
when I run Rgui, I encounter a floating point exception. To be concrete if I

 > library(nlme)
Loading required package: lattice
 > data(Rail)
 > lme(travel ~ 1, data = Rail, random = ~ 1 | Rail)

(the first example in Pinheiro and Bates), R churns for a while and a 
window pops up informing me of an application error. Specifically, "The 
exception Floating-point division by zero. (0xc000008e) occurred in the 
application at location 0x639b50ff." There error occurs every time. The 
same analysis runs flawlessly in Rterm.

To make it even stranger, I get the same error on a Toshiba Pentium 
laptop (also with 512MB of memory, although I haven't tried the analyses 
in Rterm on that machine). On that machine, I get a blue screen after 
acknowledging the error. The laptop is a dual boot on which I run Linux 
(Fedora Core 1). R works perfectly on it under Linux.

I've downloaded and re-installed the binaries on both machines several 
times, so I don't think I have a corrupted download. Any ideas on how to 
diagnose (and solve) this problem would be greatly appreciated.


Kent E. Holsinger                kent at darwin.eeb.uconn.edu
-- Department of Ecology & Evolutionary Biology
-- University of Connecticut, U-3043
-- Storrs, CT   06269-3043

More information about the R-help mailing list