[R] Problems with R CMD INSTALL on SUSE-LINUX 9.0

Joerg Polzehl polzehl at wias-berlin.de
Fri Feb 13 19:19:44 CET 2004

Dear Colleagues,

     I've recently upgraded to SUSE-LINUX 9.0 and R 1.8.1  (using the 
RPM-'s from CRAN).
I've checked that all required LINUX-Packages as listet in the 
README.html in /bin/linux/SUSE
are installed.

I've then tried to INSTALL and check a package.

Installation with

R CMD INSTALL -l Rcontrib aws
* Installing *source* package 'aws' ...
** libs
make: »aws.so« ist bereits aktualisiert.
** help
 >>> Building/Updating help pages for package 'aws'
     Formats: text html latex example
* DONE (aws)

looks fine.

When I try to use the package I get the following:

polzehl at dhcp-154:~> R

R : Copyright 2003, The R Foundation for Statistical Computing
Version 1.8.1  (2003-11-21), ISBN 3-900051-00-3

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions.
Type 'license()' or 'licence()' for distribution details.

R is a collaborative project with many contributors.
Type 'contributors()' for more information and
'citation()' on how to cite R in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or
'help.start()' for a HTML browser interface to help.
Type 'q()' to quit R.

 > library(aws)
 > aws
Error: Object "aws" not found
 > ls(pos=2)

The reason is easy to detect:

polzehl at dhcp-154:~> cd Rcontrib/aws
polzehl at dhcp-154:~/Rcontrib/aws> ls
CONTENTS  DESCRIPTION  help  html  INDEX  latex  libs  man  Meta  R-ex

INSTALL has not created an directory for the source code ... .

Did I miss something ???   May I need to install some additional package 
from the SUSE-LINUX-distribution ?

Any suggestion is highly appreciated.

Best regards and thanks in advance,

Jörg Polzehl

PS 1: I also tried to install R 1.8.1. from the sources. Everything runs 
as it sould. The base system was working correctly,
installing packages from CRAN works, but again R CMD INSTALL did not 
create the directory for the R-code.

PS 2: The same library installs correctly with   Rcmd INSTALL aws  under 
WINDOWS XP and R 1.8.1.
If I just copy the missing directory from the WINDOWS Installation 
everything works. So the problem either
lies with my LINUX-Box or the INSTALL script ...


More information about the R-help mailing list