[R] building packages on Windows

Sundar Dorai-Raj sundar.dorai-raj at pdf.com
Mon Jul 11 21:21:07 CEST 2005

Hi, all,

I just recently upgraded my computer though I'm using the same OS (XP).
But now I'm having difficulty building packages and I cannot seem to
solve the problem. I'm using R-2.1.1pat on Windows XP.

Here is what I tried:

D:\Users\sundard\slib\sundar\R>R CMD CHECK sundar
* checking for working latex ... OK
* using log directory 'D:/Users/sundard/slib/sundar/R/sundar.Rcheck'
* using R version 2.1.1, 2005-06-21
* checking for file 'sundar/DESCRIPTION' ... OK
* this is package 'sundar' version '1.1'
* checking if this is a source package ... OK

installing R.css in D:/Users/sundard/slib/sundar/R/sundar.Rcheck

---------- Making package sundar ------------
   adding build stamp to DESCRIPTION
   installing NAMESPACE file and metadata
Error in file(file, "r") : unable to open connection
In addition: Warning message:
cannot open file

Execution halted
make[2]: *** [nmspace] Error 1
make[1]: *** [all] Error 2
make: *** [pkg-sundar] Error 2
*** Installation of sundar failed ***

Removing 'D:/Users/sundard/slib/sundar/R/sundar.Rcheck/sundar'
Installation failed.

I've also tried to remove the NAMESPACE which then passes `check' but
fails on `build' with the following:

* checking for file 'sundar/DESCRIPTION' ... OK
* preparing 'sundar':
* checking DESCRIPTION meta-information ... OK
* removing junk files
Error: cannot open file 'sundar/DESCRIPTION' for reading

If this is relevant, here is my PATH:
C:\Program Files\Insightful\splus62\cmd;
C:\Program Files\HTML Help Workshop

Here, the D:\R\tools\bin directory contains the utilities for building R
from source, downloaded today. Am I missing something obvious?



More information about the R-help mailing list