[R] Problems with R on OS X

Bill Northcott w.northcott at unsw.edu.au
Tue Jul 12 01:48:16 CEST 2005

On 11/07/2005, at 8:00 PM, Heinz Schild wrote:
> I used R on OS X 10.3x quite some time with no serious problems.
> Sometimes R stopped when I tried to execute a bigger program. After
> updating to OS X to version 10.4 R worked but I still had the problem
> with bigger programs. Therefore I re-installed R on top of the
> existing R version. The installation finished properly but suddenly R
> did not work. Then I reinstalled OS X 10.4 because I thought some
> left over registry information from R may caused the problem. R still
> crashed. I hoped the problem would be overcome with the new R version
> 1.12. Unfortunately this is not the case. The error report (see
> appendix) says that Thread 0 crashed.
> What can I do?
> Heinz Schild

The best place for MacOS issues is the r-sig-mac list to which I have  
copied this mesage.

MacOS X does not have a registry!  Configuration files for MacOS  
applications live in ~/Library/Preferences.  The file for the R GUI  
app is called org.R-project.R.plist.  The rest of R on a Mac is just  
like any other UNIX platform with settings and history in ~/.Rdata  
and ~/.Rhistory.  (Files starting with a period '.' are invisible in  
the MacOS desktop.)  If you want to trash the configuration just  
delete these three files.

The version 1.12 you quote is only for the GUI, which is just a front  
end for the R framework.  The current version of the framework binary  
is 2.1.1, which you will see on the 'R Console' window when you start  
the application.  If you try the 1.12 GUI with a version of the  
framework other than 2.1.1 it is very likely to crash.  If you  
install the complete package from CRAN it will install both the GUI  
application and the framework.

BIll Northcott

More information about the R-help mailing list