[R] Can't get sample function from "An Introduction to R" to work

David Groos david.groos at mpls.k12.mn.us
Sat Jul 16 05:47:01 CEST 2005

Thank you-all very much for your help, your responses and help has been 
very encouraging.  The following doesn't close the case but it tables 

First I copied Ken's code into my R Console and...it worked great!  
That was baffling as it looked identical to mine.

I did not explicitly say earlier that the code I sent out I had copied 
from the console, pasted into MS Word, changed font size, then pasted 
it into the e-mail--in other words, that was a copy of one of the codes 
that didn't work.

Anyway,  I then copied the non-working, pasted it into Console, 
expecting that it would say "Error: syntax error" upon pressing the 
return key at the end of this line:
>> + tst<-(yb1-yb2)/sqrt(s*(1/n1+1/n2))
but it didn't!  and the code worked this time, also!
I then went about doing what I could to replicate the error from before 
and was as unsuccessful in doing that as I was in making it work, 

On Jul 15, 2005, at 4:43 PM, Peter Dalgaard wrote:

> "Bret Collier" <bret at tamu.edu> writes:
>> David,
>> If below is exactly what you typed, check your code again, I think you
>> are missing a '}' after the last 2 parentheses.
> That's not supposed to cause a syntax error, just another '+'.
(right! that's what I thought...)
> I can copy and paste the code as written and not get an error:
>> twosam<-function(y1, y2) {
> + n1<-length(y1);n2 <-length(y2)
> + yb1<-mean(y1); yb2<-mean(y2)
> + s1<-var(y1);s2<-var(y2)
> + s<-((n1-1)*s1 + (n2-1)*s2)/(n1+n2-2)
> + tst<-(yb1-yb2)/sqrt(s*(1/n1+1/n2))
> + }
> Perhaps this was the 1st time David got his typing right? The error is
> of the sort you'd get if you had
>  s<-((n1-1)*s1 + (n2-1)*s2/(n1+n2-2)
Interestingly enough, I did try this line when first I was trying to 
make the code work and with just 1 ")" at the end I didn't get the 
error message, but then again I wasn't able to make the whole program 
work, either.

In conclusion, I can't explain why it didn't first work time nor why I 
couldn't replicate the error.  I think I ought to e-mail the Mac R 
folks about this.

Again, Thanks,


More information about the R-help mailing list