[R] package (!) mclust in 64bit compiled R

Martin Maechler maechler at stat.math.ethz.ch
Wed Jul 20 09:19:25 CEST 2005

>>>>> "TaeHC" == Tae-Hoon Chung <thchung at tgen.org>
>>>>>     on Tue, 19 Jul 2005 10:26:01 -0700 writes:

    TaeHC> Hi, All; I tried to use library mclust in 64-bit
    TaeHC> compiled R 2.0.1 but failed.  

you mean   "package  mclust"
{a package is installed in a library full of packages}

    TaeHC> Installation went smoothly without any warning or
    TaeHC> error. However, when I tried to use them with the
    TaeHC> following simple code, it crashed.

 >      library(mclust)
 >      Dat <- c(rnorm(20, mean=0, sd=0.2), rnorm(30, mean=1, sd=0.2))
 >      Ind <- Mclust(dat, 1, 5)$classification
 >      cbind(Dat, Ind)

My desktop has been a 64-bit (AMD Athlon 64) for more than a
year now, and I do note small differences to 32-bit some times,
and even have found (and not yet solved) quite severe problem
with the akima package.

Not with 'mclust' though.
I've just run several 1000 of Mclust() fits like the one above
and not seen any problem.

    TaeHC> The error message was:

    TaeHC> /usr/local/R-2.0.1_64bit/lib/R/bin/BATCH: line 55:
    TaeHC> 18097 Done ( echo "invisible(options(echo = TRUE))";
    TaeHC> cat ${in}; echo "proc.time()" ) 18099 Segmentation
    TaeHC> fault | ${R_HOME}/bin/R ${opts} >${out} 2>&1

    TaeHC> Can anybody help me with this?  Thanks in advance,

- Does *every* call to Mclust() give a segmentation fault?

- I assume you -- or someone in your group has compiled this R version
from source.  Did you (or he/she) run  "make check" after
building from source?  Could you (or ..) asks to run it?

- What output do you get when you run 
  R -d gdb

  then the above R code,
  and then maybe type 'bt' (backtrace) ?

Martin Maechler, ETH Zurich

More information about the R-help mailing list