[R] Problem with data editor when R built with --enable-mcfs

gginiu gginiu at gmail.com
Sat Dec 1 17:26:36 CET 2007


I encountered this problem when I was looking around in R, by default
R is built with --enable-mcfs and when I tried to edit any data I was

dataentry(datalist, modes) : invalid device
unable to create fontset -*-fixed-medium-r-normal--13-*-*-*-*-*-*-*

anyway I looked around code, noticed that it comes from fragment when
SUPPORT_MCFS is defined, and decided to try my luck without it,
rebuild with:


and it worked like a charm, just doesn't have UTF-8 support now of
course what would be nice... am I missing something? I googled and
searched and found one similar message, but then it was stated it
works with current versions... my fonts in xorg.conf points to right
directories in my system and all other apps works. I run current
version of Arch linux

I would appreciate any help or hints how to solve that - whatever this
is bug or misconfiguration :)
thanks in advance,
Andrzej Giniewicz.

More information about the R-help mailing list