[R] Analyzing Publications from Pubmed via XML

Armin Goralczyk agoralczyk at gmail.com
Tue Dec 18 16:02:52 CET 2007

On 12/18/07, David Winsemius <dwinsemius at comcast.net> wrote:
> David Winsemius <dwinsemius at comcast.net> wrote in
> news:Xns9A09CA51DB1E4dNOTwinscomcast at
> > "Armin Goralczyk" <agoralczyk at gmail.com> wrote in
> > news:a695fbee0712171238g4995040x579e58f52f83376e at mail.gmail.com:
> >> I tried the above function with simple search terms and it worked
> >> fine for me (also more output thanks to Martin's post) but when I use
> >> search terms attributed to certain fields, i.e. with [au] or [ta], I
> >> get the following error message:
> >>> pm.srch()
> >> 1: "laryngeal neoplasms[mh]"
> >> 2:
> > I am wondering if you used spaces, rather than "+"'s? If so then you
> > may want your function to do more gsub-processing of the input string.
> I tried my theory that one would need "+"'s instead of spaces, but
> disproved it. Spaces in the input string seems to produce acceptable
> results on my WinXP/R.2.6.1/RGui system even with more complex search
> strings.
> --

It's not the spaces, the problem is the tag (sorry that I didn't
specify this), or maybe the string []. I am working on a Mac OS X 10.4
with R version 2.6. Is it maybe a string conversion problem? In the
following warning strings in the html adress seem to be different:

Fehler in .Call("RS_XML_ParseTree", as.character(file), handlers,
as.logical(ignoreBlanks),  :
 error in creating parser for
I/O warning : failed to load external entity

Armin Goralczyk, M.D.
Universitätsmedizin Göttingen
Abteilung Allgemein- und Viszeralchirurgie
Rudolf-Koch-Str. 40
39099 Göttingen
Dept. of General Surgery
University of Göttingen
Göttingen, Germany

More information about the R-help mailing list