[R] Problems with EMACS-ESS on Ubuntu

Ben Bolker bolker at ufl.edu
Tue Dec 25 03:51:48 CET 2007

Tom La Bone <booboo <at> gforcecable.com> writes:

> I installed EMACS-ESS on Windows XP-Pro and it worked with R perfectly right
> out of the box. I was impressed with how easy it is to use (I normally use
> Tinn-R). I then switched over to Ubuntu 7.10 and installed EMACS-ESS.
> Everything worked the same as in Windows (which is my main reason for using
> EMACS) until I tried to send a line of code from the EMACS buffer to R -- R
> is running but the code just will not go to it. All I get is a line at the
> bottom of the editor window that says "Process to load into: R". I am new to
> EMACS and did not see any fixes that looked promising in the ESS manual. Can
> anyone offer some suggestions on things to check? Thanks.

  Emacs just wants you to confirm which buffer the code is getting
sent to (and the buffer called "R" is its default).  The focus should
automatically have gotten set to the mini-buffer at the bottom of the
window, so if you just hit ENTER in response to this query everything
should work fine!

  Ben Bolker

More information about the R-help mailing list