[R] ASUS Eee R cookbook

John C Frain frainj at gmail.com
Sat Dec 29 15:17:04 CET 2007

About a year ago I looked at running R (and the Rmetrics packages) on
an early UMPC Samsung Q2  with 512 GB of memory.  I ran R from a USB
flash memory drive and execution times were about twice that on my
current desktop PC with 2 GB memory and an Intel Core 2 Duo E6600
(2.4GHz).  I know that the relative results are probably specific to
the particular program that I was testing but they speak volumes for
the CPU in the Samsung Q2 which is the same as that in the Asus EEE
PC.  My desktop is running Windows XP Professional and the Samsung was
running the tablet version of Windows XP.

Given the small internal flash memory on the EEE PC I wonder if anyone
has tried to run R from an external flash drive in Linux.  Could one
expect as good a performance from the EEE PC as I got from the
Samsung.  (I also tried some TeX compilations from flash memory on the
Samsung with satisfactory results.  The Samsung  is about the same
size as the EEE PC but is a multiple of the cost.  I suspect that the
current price of the EEE PC will fall as soon as supply increases and
some other manufacturers enter the market. It would be great to be
able to have so portable a device that was capable of running R,
LaTeX, Octave, Mathematica etc, as well as open office and firefox.

On 29/12/2007, Jim Lemon <jim at bitwrit.com.au> wrote:
> Hi all,
> Having seen a few messages regarding the ASUS Eee PC (p701) and R, and
> then buying one and trying to get R installed on it, I thought there
> might be a few people on the list who would appreciate a cookbook on how
> to do it. It's a nice little piece of machinery, running Xandros 4 Linux
> (seems to be compatible with Debian Etch) and set up for the person who
> wants to do all those Webby things plus maybe a bit of office type work.
> All that works right out of the box. However, getting R going took me a
> few tries.
> First get your Eee an internet connection. This was embarrassingly easy
> for me, I just plugged it into the D-Link router, clicked the LAN option
> and in a few seconds I was online. It also has wireless and even yer old
> bleep-buzz modem options.
> You may be able to run R on the Easy Desktop, but I went straight to the
> Full Desktop (KDE). There is an excellent description of how to download
> the necessary files and enable KDE at:
> http://wiki.eeeuser.com/howto:getkde
> This gives you what most people who use Linux are used to (you can
> apparently enable GNOME, too). Now for the fun. I wasn't able to compile
> R from source as gcc wouldn't go. I'll let you know if I get it working.
> As in setting up KDE, you have to add a repository.
> 1a. Applications|System|Synaptic Package Manager
> OR
> 1b. Start a console, su to root and enter "synaptic"
> 2. Alt-S (Settings) | R (Repositories)
> 3. Alt-N (New)
> 4. Enter the URI of the repository, the distribution and the section(s)
> This is where I ran afoul of the Debian voodoo. You don't actually enter
> the URI, just the bit before "dists" (I think). Then you enter the
> distribution (etch) and then "main". After many tries, my entry looks
> like this:
> URI: ftp://ftp.au.debian.org/debian/
> Distribution: etch
> Section(s): main
> while the actual URI is:
> ftp://ftp.au.debian.org/debian/dists/etch/Contents-i386.gz
> Maybe there is a better way. I'm happy to be corrected. The package
> listing will then download. When complete:
> 5. Scroll down to the "r-base" package, right click and select "Mark for
> Installation".
> 6. Click "Apply" near the top of the window.
> 7. Confirm in the dialog that appears and it should all happen.
> At this point, I went off for lunch, as it looked like taking half an
> hour or so. The power pack on the Eee has those annoying half-shielded
> prongs and it had come loose at some point. When I returned, the Eee had
> shut down. Every time I powered it up, it would shut down again. I
> reverted to the factory settings using F9 on bootup (thereby losing all
> my upgrades) and it still kept shutting down, faster each time. I
> finally worked out that the battery had gone critically flat, recharged
> it, went through the whole process again and it works fine.
> One thing that helps a lot is to resize the graphics window as the
> screen is kind of small. I tried:
> x11(width=5,height=5)
> and it didn't quite work, but then something I did (hit the wrong key?
> unintentionally clicked on something?) worked and it seemed to remember
> whatever I had done. Now my plots fit on the screen.
> I have installed a few source packages, but until I get gcc to go, I
> will have to use synaptic to install anything that requires compilation.
> If I have made any gross mistakes or any of this doesn't appear to work,
> please let me know. I think it's absolutely fantastic to have R running
> on something that I can stick in a large pocket.
> Jim
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

John C Frain
Trinity College Dublin
Dublin 2
mailto:frainj at tcd.ie
mailto:frainj at gmail.com

More information about the R-help mailing list