[R] data.restore() in R 2.5.1 for Windows 95 and later

Brad Christoffersen bchristo at email.arizona.edu
Tue Jul 17 05:38:32 CEST 2007

To Whom It May Concern:

I want to read in an S-PLUS data dump and I used

> data.restore("filepath/filename")

(in R 2.5.1 for Windows 95 and later) and I get the message

Error: could not find function "data.restore"

I have also tried read.S() and read.dta() with the same result.  I cannot find
any of these functions in the R Help for package base, although data.restore()
is mentioned in the R Data Import/Export manual.  I have also tried apropos()
and "character(0)" returns.  Additionally, I tried

> getS3method("data","restore")

but get

Error in getS3method("data", "restore") : no function 'data' could be found

In addition, I tried

> dget("filepath/filename")

and it was taking a very long time to import the desired data dump objects which
previously took a shorter time using data.restore in SPlus.

Any help is much appreciated!


Brad Christoffersen
Graduate Student
University of Arizona

More information about the R-help mailing list