[R] Problems installing lme4 on Ubuntu

Bill Harris bill_harris at facilitatedsystems.com
Sat Dec 20 05:07:45 CET 2008

Hash: SHA1

Dirk Eddelbuettel <edd at debian.org> writes:

> First off, see the R FAQ and the Ubuntu README on CRAN:
>    http://cran.r-project.org/bin/linux/ubuntu/


Thanks; that looks promising!

> This shows you how you can get current R binaries with just one apt-get
> command.  With that, you then get to decide if you want the prebuild r-cran-*
> packages (as e.g. r-cran-lme4) or whether you want to built them yourself in
> R via install.packages().  In which case r-base-dev will be helpful to
> install needed packages.

I tried that, but using the mirrors at fhcrc and wustl both gave me
errors when I tried to install: 

| WARNING: The following packages cannot be authenticated!
|   ess r-base-core r-cran-lattice r-cran-mgcv r-cran-vr r-base r-recommended
|   r-cran-rodbc r-base-html
| Install these packages without verification [y/N]? 

Is that to be expected?  I aborted the process, but, if you say that's
normal, I'll try again.

> Either way, I have no problems with lme4 etc. or arm, see below.
> Also note that there is a Debian/Ubuntu specific mailing list r-sig-debian
> where you may want to subscribe.  You are likely to find more focussed help
> for Ubuntu there, and we'd be glad to walk you through individual steps.
> Welcome to Debian and Ubuntu :)

Thanks.  I'll sign up shortly.  I had used Debian some years ago in a
colinux setting, and it's truly fun to compute again now that I'm on Ubuntu.

>         The following object(s) are masked from package:stats :
>          xtabs

Ah.  So, whatever that means, it must be okay. :-)

- -- 
Bill Harris                      http://facilitatedsystems.com/weblog/
Facilitated Systems                              Everett, WA 98208 USA
http://facilitatedsystems.com/                  phone: +1 425 337-5541
Version: GnuPG v1.4.9 (GNU/Linux)


More information about the R-help mailing list