[R] Trouble installing plyr

Andrew Choens andy.choens at gmail.com
Mon Dec 29 20:15:17 CET 2008

I want to learn how to use the reshape package. The reshape package is
not included in the Ubuntu repositories, so I attempted to install
reshape with:


This is what I got for output:

        Warning in install.packages("reshape") :
          argument 'lib' is missing: using
        --- Please select a CRAN mirror for use in this session ---
        Loading Tcl/Tk interface ... done
        trying URL
        Content type 'application/x-gzip' length 38137 bytes (37 Kb)
        opened URL
        downloaded 37 Kb
        * Installing *source* package 'reshape' ...
        ** R
        ** data
        **  moving datasets to lazyload DB
        ** inst
        ** preparing package for lazy loading
        Loading required package: plyr
        Warning in library(pkg, character.only = TRUE, logical.return =
        TRUE, lib.loc = lib.loc) :
          there is no package called 'plyr'
        Error: package 'plyr' could not be loaded
        Execution halted
        ERROR: lazy loading failed for package 'reshape'
        ** Removing '/home/andy/R/i486-pc-linux-gnu-library/2.7/reshape'
        The downloaded packages are in
        Warning messages:
        1: In install.packages("reshape") : dependency ‘plyr’ is not
        2: In install.packages("reshape") :
          installation of package 'reshape' had non-zero exit status

I tried this, using several different mirrors, hoping that the problem
was isolated to the PA mirrors. But, no matter which mirror I use, I get
the same error. My central problem appears to be an inability to install
        > install.packages("plyr")
        Warning in install.packages("plyr") :
          argument 'lib' is missing: using
        Warning message:
        In install.packages("plyr") : package ‘plyr’ is not available

Again, the mirror does not matter. I can not install plyr. I am pretty
confident that my syntax is correct, but I do not understand why I can
not install plyr. I don't think the problem is related to my connection,
since this computer is able to surf the Internet and send email (such as
this one). When I googled for problems installing plyr, I got a zillion
instructions on how to install the XXXX player.

Ideas are appreciated.

Insert something humorous here.  :-)

More information about the R-help mailing list