[R] Packfor library-problem downloading

tub78 stu.andrews at gmail.com
Wed Jun 4 21:55:29 CEST 2008


I believe we have the same problem.  For a hacky solution, please see
my post

- Stu

On May 22, 11:05 am, Jubilo <jucpgar... at gmail.com> wrote:
> Hello,
> I'm a new user to R, and I was trying to install "packfor" in my R console
> and I always run into an error.
> I tried to search, in in the forum, someone that already might have made the
> same question, but all I could find was a general information how to install
> libraries in R.
> Pass through all that procedure (Package&Data->Package Installer->Local
> Source Package[because my library was in a folder in my computer]), I have a
> message that is "DONE", but then I do the command "library(packfor)" and I
> get an error message:
> --------------------------------------------------------------------------- --WARNING:ignoringenvironment value ofR_HOME
> * Installing *binary* package 'packfor' ...
> * DONE (packfor)
> > library(packfor)
> packfor: R Package for Forward Selection (Canoco Manual p.49)
> version 0.0-8Error in dyn.load(file, DLLpath = DLLpath, ...) :
>   unable to load shared library
> '/Library/Frameworks/R.framework/Versions/2.7/Resources/library/packfor/lib s/i386/packfor.so':
> dlopen(/Library/Frameworks/R.framework/Versions/2.7/Resources/library/packf or/libs/i386/packfor.so,
> 6): Library not loaded: /usr/local/lib/libgfortran.2.dylib
>   Referenced from:
> /Library/Frameworks/R.framework/Versions/2.7/Resources/library/packfor/libs /i386/packfor.so
>   Reason: image not found
> Error in library(packfor) : .First.lib failed for 'packfor'
> --------------------------------------------------------------------------- -----------------------------------
> I have a mac where I installed R2.7.0, and I want to use the
> "packfor_0.0-8_for_R2.7.tar.gz". I already uninstalled R twice and installed
> it again, I already used another packfor file, from another person... I ran
> out of ideas so I would like a little bit of help.
> My R also presents an other error when it starts:
> -----------------------------------------------------
> During startup -Warningmessages:
> 1: Setting LC_CTYPE failed, using "C"
> 2: Setting LC_COLLATE failed, using "C"
> 3: Setting LC_TIME failed, using "C"
> 4: Setting LC_MESSAGES failed, using "C"WARNING: You're using a non-UTF8 locale, therefore only ASCII characters
> will work.
> Please read R for Mac OS X FAQ (see Help) section 9 and adjust your system
> preferences accordingly.
> ----------------------------------------------------------
> I don't know if this is important to solve the issue, but anyway I already
> done other analysis (which means that I used other libraries) and I didn't
> have any problem. Besides the section 9 from the Help talks about version
> previous the one that I have (1.0.1, 2.0 and 2.1).
> Thanks in advance for any idea that you might have ,
> Ju
> --
> View this message in context:http://www.nabble.com/Packfor-library-problem-downloading-tp17406291p...
> Sent from the R help mailing list archive at Nabble.com.
>         [[alternative HTML version deleted]]
> ______________________________________________
> R-h... at r-project.org mailing listhttps://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guidehttp://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list