[R] Fatal error: unable to restore saved data in .RData

Thompson, David (MNR) David.John.Thompson at ontario.ca
Fri Oct 10 16:25:53 CEST 2008


I am unable to start an R session by double-clicking on an existing
.RData file from the Windoze file explorer.
A dialogue appears with the message
	"Fatal error: unable to restore saved data in .RData",

and I notice in the R Console the last few lines are:
	"Loading required package: R2HTML
	 error in function ()  : unused argument(s) (1:43)"

I tried starting a fresh R session, changing the working directory,
saving a new empty workspace, closing R, and restarting with the new
(empty) .RData file to the same effect.

I tried with the --vanilla option, changing the working directory and
loading the existing workspace,  and get the error message:
	"Error in function ()  : unused argument(s) (1:43)"

And again with the --no-restore-data option, same effect.

Thanx, DaveT.
# system info:
> sessionInfo() ; cat("\n") ; Sys.info()[c(1:3,5)]
R version 2.7.2 (2008-08-25) 


attached base packages:
[1] stats     graphics  grDevices datasets  tcltk     utils     methods

other attached packages:
[1] debug_1.1.0     mvbutils_1.1.1  lattice_0.17-14 plotrix_2.4-7
svSocket_0.9-5  TinnR_1.0.2     R2HTML_1.59     Hmisc_3.4-3    

loaded via a namespace (and not attached):
[1] cluster_1.11.11 grid_2.7.2      svMisc_0.9-5    tools_2.7.2    

  sysname                      release                      version
"Windows"                         "XP" "build 2600, Service Pack 2"
# system info:
Silviculture Data Analyst
Ontario Forest Research Institute
Ontario Ministry of Natural Resources
david.john.thompson at ontario.ca

More information about the R-help mailing list