[R] 2.8.0 on Mac: libR.dylib

Chris Lokan c.lokan at adfa.edu.au
Tue Oct 28 12:42:19 CET 2008

I use a Macbook Pro laptop, running OX X 10.4.11. I have been running R
2.7.1 with no problems for years, including installing packages such as
chron, Cairo, Design.

Today I downloaded R 2.8.0 from my local mirror in Australia. (The md5
result matched the code on the download page.) I then used
R CMD INSTALL to install separately-downloaded versions of chron, Cairo
etc, as I have done with previous versions of R.

When I then ran R, and tried to load Cairo this is what I got:

Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared library
libs/i386/Cairo.so, 6): Library not loaded:
  Referenced from: 
  Reason: image not found
Error : .onLoad failed in 'loadNamespace' for 'Cairo'
Error: package/namespace load failed for 'Cairo'

It seems that missing libR.dylib is my problem.

Completely uninstalling R and then reinstalling did not resolve the problem.

I also tried a fresh download today from another mirror (BC in Canada), but
that didn't help.

I am sure I have made a dumb mistake. How do I fix things?


More information about the R-help mailing list