[R] Eror message: not a valid package -- installed < 2.0.0

Powers, Randall - BLS Powers.Randall at bls.gov
Thu Feb 12 16:26:30 CET 2009

I am running 2.6.0 because I can't seem to get 2.8.1 configured

When I do ./configure, it goes through a long list, and ends with

 configure: error: --with-iconv=yes (default) and a suitable iconv is
not available

When I run make, I get the message below.

# make
make: not found

So does anybody have any help regarding how do get the install to work?
Otherwise, I am stuck with 2.6.0.


-----Original Message-----
From: r-help-bounces at r-project.org [mailto:r-help-bounces at r-project.org]
On Behalf Of Ben Bolker
Sent: Wednesday, February 11, 2009 2:49 PM
To: r-help at r-project.org
Subject: Re: [R] Eror message: not a valid package -- installed < 2.0.0

   Is there any reason you can't just install an up-to-date version of R
(R 2.8.1), from cran.us.r-project.org (or your favorite mirror, see
www.r-project.org) and see if that fixes the problem?  Installing R on
SunOS is not quite the breeze that it is on MacOS, Windows, or Linux,
but it's not that bad ... and you are much more likely to get help from
the list if you make it worth people's while to help you by either (1)
explaining why you are stuck with an old version [regulatory
compliance/mission-critical old R software] or (2) installing recent R
and showing that the problem persists.

 Ben Bolker

Powers, Randall - BLS wrote:
>> Hello R-help,
>> We are running R version 2.6.0 (2007-10-03). I believe that I got it 
>> from www.sunfreeware.com. A number of the packages that we attempt to

>> download from http://www.r-project.org/  give us the error message 
>> below when we attempt to run them.

View this message in context:
Sent from the R help mailing list archive at Nabble.com.

R-help at r-project.org mailing list
PLEASE do read the posting guide
and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list