[R] Problem with package SNOW on MacOS X 10.5.5

Rainer Machne raim at tbi.univie.ac.at
Sat May 9 18:04:37 CEST 2009

Hi Greg,

I don't know if this is related to your problem, but
I get the same error (on both ubuntu and fedora linux, R 2.9) and just 
found a very curious behaviour - snowfall apply functions don't like the 
variable name "c".


sfLapply(1:10, exp)

issues the same error you had posted, while subsequent

sfLapply(1:10, exp)

runs fine.


On Wed, 31 Dec 2008, Greg Riddick wrote:

 > Hello All,
 > I can run the "lower level" functions OK, but many of the higher level
 > (eg. parSApply) functions are generating errors.
 > When running the example (from the snow help docs) for parApply on
 > MacOSX 10.5.5, I get the
 > following error:
 > cl <- makeSOCKcluster(c("localhost","localhost"))
 > sum(parApply(cl, matrix(1:100,10), 1, sum))
 > Error in do.call("fun", lapply(args, enquote)) :
 > could not find function "fun"
 > Any ideas? Do I possibly need MPI or PVM to run the "Apply" functions?
 > Thanks,

More information about the R-help mailing list