[R] how can I read a non-standard XLS file

Gabor Grothendieck ggrothendieck at gmail.com
Tue May 25 13:29:01 CEST 2010

It appears you are using read.xls in gdata.  In that case be sure you
are using the latest version of gdata on CRAN since there was a
problem with one older version.   There is more info on read.xls in
gdata here and also listed there are alternatives you can try:

On Tue, May 25, 2010 at 7:12 AM,  <mauede at alice.it> wrote:
> I have attached a file downloaded from database mirWalk.
> Apparently it is in XLS format (this is the extension of the downloaded file).
> However, I cannot open it with OpenOffife spreadsheet program and Excel itself
> cannot separate the columns as it does when a true XLS file is loaded.
> I tried to read the attached downloaded file through R function "read.xls"
> and got the following message
>> read.xls("Prostatic_Neoplasm-miRNAs.Disease-GenesTargets.xls")
> Error in xls2sep(xls, sheet, verbose = verbose, ..., method = method,  :
>  Unable to read translated csv file '/tmp/RtmpPIe3vo/file15d9580e.csv'.
> Error in file.exists(tfn) : invalid 'file' argument
> I have tried reading the file through "read.table" which has now been hanging for
> more than 15 minutes.
> Please, advice.
> Thank you in advance.
> Maura
> e tutti i telefonini TIM!
> Vai su
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list