[R] Installing binaries from R-Forge

Millo Giovanni Giovanni_Millo at Generali.com
Mon Nov 14 14:58:03 CET 2011


I just installed R 2.14.0 and then did

> install.packages("splm", repos="http://R-Forge.R-project.org")

in order to replicate your problem. 
It worked "almost" fine. The only problem I had was with some missing
packages: being a fresh install, all suggested and required packages had
to be installed before 'splm', which is automatically done by
install.packages using the 'repos' specified: but some ('spam',
'ibdreg', 'lmtest', 'deldir', 'coda', 'sandwich') aren't available on
R-forge, so I had to install them separately beforehand.

The error you get is typical of moments when the required binary isn't
available yet, because the version is very recent and the automated
compiling process hasn't completed its runs. This isn't a problem with
'splm' because the current version is some months old. In turn, R 2.14.0
was 9 days old at the time of your message, so maybe recompiling wasn't
done yet.

An alternative install, also not requiring the very last R version, is
to download splm_0.9-05.zip to a local folder and install from there. If
you are on Windows, you can always do this through the graphical menu
(Packages > install from local .zip file). If on Linux, same but through
command line.

It would be useful to know 
- whether the problem persists now
- which system are you using etc.

This last piece of information is **required posting info**, and cited
in the posting guide (which in turn is required reading for
non-programmers alike). You can do

> sessionInfo()

Let me know how you get along with this.

Giovanni Millo, PhD
Research Dept.,
Assicurazioni Generali SpA
Via Machiavelli 4,
34132 Trieste (Italy)
tel. +39 040 671184
fax  +39 040 671160

----------- Original message -------------------

Message: 3
Date: Wed, 9 Nov 2011 07:39:09 -0500
From: "Downey, Patrick" <PDowney at urban.org>
To: <r-help at r-project.org>
Subject: [R] Installing binaries from R-Forge
	<0F96478603980B46AAAFBA77069582ED131C7C95 at UIEXCH.urban.org>
Content-Type: text/plain;	charset="us-ascii"


I'm attempting to install the splm package from R-Forge.


The page says, "In order to successfully install the packages provided
R-Forge, you have to switch to the most recent version of R..." It later
says "To install this package directly within R type:
install.packages("splm", repos="http://R-Forge.R-project.org")".

I just installed R-2.14 and I still get the following error message.

Warning message:
In getDependencies(pkgs, dependencies, available, lib) :
  package 'splm' is not available (for R version 2.14.0)

Can someone please help? I understand that there is relevant information
the posting guide, but I'm not a programmer and it's difficult for me to
understand. I thought I've followed the advice from previous posts
(notably, upgrade).

Thank you,

----------- end original message -------------------

Ai sensi del D.Lgs. 196/2003 si precisa che le informazi...{{dropped:12}}

More information about the R-help mailing list