[R] readDGE: Error in colnames/length of dimnames not equal to array extent

jazevedo stepsbeyondmadness at gmail.com
Mon Nov 21 21:43:04 CET 2011

Hello, all,

I'm a new R user (new to any programming language in general, really), so I
apologize if this is easy/has already been answered (I've attempted
searching online but did not understand the pages I found).

My data is stored in text files with the headers LANE, RNA_NAME, SEQ, and
SEQCNT. I've been using

x = "filename.txt"
y = aggregate(x$SEQCNT, list(x$RNA_NAME), sum)
write.table(y, "C:/path/filename.txt", sep="\t")

to generate an output that I've analyzed using readDGE in the edgeR package:

>RNA Targets = read.delim("Targets.txt", stringsAsFactors = FALSE)
Files      Groups
A.txt     1
B.txt     2
>v = readDGE(Targets, skip = 5, comment.char = "!")

I've done this several times; until yesterday, it worked fine. Today,
however, an error message started cropping up after attempting readDGE:

Error in `colnames<-`(`*tmp*`, value = c("1", "2")) : 
  length of 'dimnames' [2] not equal to array extent

I've tried to figure this out with no luck, so absolutely any help would be
appreciated. Thank you all!

View this message in context: http://r.789695.n4.nabble.com/readDGE-Error-in-colnames-length-of-dimnames-not-equal-to-array-extent-tp4093251p4093251.html
Sent from the R help mailing list archive at Nabble.com.

More information about the R-help mailing list