[R] dir.create() does not create directory

R. Michael Weylandt <michael.weylandt@gmail.com> michael.weylandt at gmail.com
Sat Nov 26 16:18:51 CET 2011

I'm not a Windows man, but have you tried in the R CLI or GUI rather than Eclipse? That would help narrow down the problem. 

Also, if you could provide a minimal example for those who have Windows boxes that'd be great - though admittedly it sounds hard here. 

As an outline, something like:


should suffice. 


On Nov 26, 2011, at 10:07 AM, syrvn <mentor_ at gmx.net> wrote:

> Hello,
> I am running Windows 7 and R-2.13 in StatET. 
> When I try to create a directory it does not print any errors but if I check
> outside eclipse if it exists or do a refresh in Eclipse the directory is not
> been created. The strange thing is that it happens only to some
> sub-folders... On the other hand when I use the normal windows explorer in
> one of these sub-folders and create a folder it works.
> Any ideas? I also tried the mode="777" option but still the same problem
> Cheers,
> syrvn
> --
> View this message in context: http://r.789695.n4.nabble.com/dir-create-does-not-create-directory-tp4110517p4110517.html
> Sent from the R help mailing list archive at Nabble.com.
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

More information about the R-help mailing list