[R] install "multtest" and "preprocessCore" packages in Bioconductor library

David Winsemius dwinsemius at comcast.net
Wed Nov 30 19:14:30 CET 2011

On Nov 30, 2011, at 12:57 PM, UyenThao Nguyen wrote:

> Hi All,
> I've tried to install these "multtest" and "preprocessCore" packages  
> in Mac, but kept getting error messages. I tried to load the  
> packages using 2 ways:
> 1. Installed from BioConductor (sources)

You should read the directions about how to start with BioConductor.  
Generally, you need to install BiocLite or some such. I forget the  
exact specifics but they are all in the accompanying documentation.  
And if you need to install from sources, see comment below.

> 2. And installed from BioConductor (binaries)
> Both ways, I got these error messages:
> For preprocessCore:
> ld: warning: directory '/usr/local/lib' following -L not found

> ld: library not found for -lgfortran

This suggests that in addition to not reading the Posting Guide (where  
you are asked not to append unrelated questions to unrelated threads   
AND you are asked to post Mac problems to the Mac list) that you also  
failed to read the Mac sections of the Installation and Administration  
Guide where you would have learned that you need to install Xcode.  
Please study that document more thouroughly if you plan to install  
from sources  ... although in this case that should not be necessary  
since the BioC repository has binaries.

> collect2: ld returned 1 exit status
> make: *** [preprocessCore.so] Error 1
> ERROR: compilation failed for package ‘preprocessCore’
> * removing ‘/Library/Frameworks/R.framework/Versions/2.10/Resources/ 
> library/preprocessCore’
> * restoring previous ‘/Library/Frameworks/R.framework/Versions/2.10/ 
> Resources/library/preprocessCore’
> For multtest:
> ld: warning: directory '/usr/local/lib' following -L not found
> ** arch - x86_64
> Looks like the error got to do with L drive, which I don't know how  
> to fix it.

There is no "L drive". Macs don't refer to their drives or partitions  
by letters. The dash indicates that "L" argument to a system command  
was not found.

> Please help. Any suggestions will be greatly appreciated.
> Thank you very much,
> Nguyen
> ______________________________________________
> R-help at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-help
> PLEASE do read the posting guide http://www.R-project.org/posting-guide.html
> and provide commented, minimal, self-contained, reproducible code.

David Winsemius, MD
West Hartford, CT

More information about the R-help mailing list