[R] Ubuntu installation

Jeff Newmiller jdnewmil at dcn.davis.CA.us
Tue Jul 31 15:42:05 CEST 2012

a) There are various routes to modifying sources.list... Ubuntu Software Center has a dialog box for it, and there are several other such tools.

b) I always copy-pasted from the instructions so I had no problems with fiddly bits.

c) Not all mirrors are created equal... sometimes you need to pick a different one to get the right combination of updated software and libraries. This changes over time, so I have never had the perfect storm of repository problems and new installation unfamiliarity to deal with.
Jeff Newmiller                        The     .....       .....  Go Live...
DCN:<jdnewmil at dcn.davis.ca.us>        Basics: ##.#.       ##.#.  Live Go...
                                      Live:   OO#.. Dead: OO#..  Playing
Research Engineer (Solar/Batteries            O.O#.       #.O#.  with
/Software/Embedded Controllers)               .OO#.       .OO#.  rocks...1k
Sent from my phone. Please excuse my brevity.

Gene Leynes <gleynes at gmail.com> wrote:

>I got R to update to the latest version
>The problem was the sources.list file.  I had not fixed the
>file correctly, which was apparent when I opened the file using
>sudo nano sources.list
>Opening the file from the command line turns on syntax highlighting (as
>opposed to opening a file from within nano using ctrl-r... who thinks
>these shortcuts?  Ctrl-o means "save"?)
>anyway... it's very important to have a space and a trailing slash...
>shown below:
>deb http://ftp.ussg.iu.edu/CRAN/bin/linux/ubuntu precise/
>When I edited that line, the update worked.
>Hope this helps someone.
>Thank you,
>   Gene Leynes
>*Data Scientist*
>On Tue, Jul 31, 2012 at 12:48 AM, Gene Leynes <gleynes at gmail.com>
>> I just followed the instructions on
>CRAN<http://cran.r-project.org/bin/linux/ubuntu/README> to install
>> R on an Ubuntu instance.
>> sudo apt-get install r-base
>> Why does it install an old version of R?  Can I install version 15.1?
>> I changed my sources.list to be a current cran mirror.  I believe
>that I
>> have entered the URL correctly because at first I had it wrong (there
>was a
>> trailing "/"), and I fixed that error.   when I run
>> sudo apt-get install r-base
>> it says that I'm at the most current version, but I can see 15.1 in
>> repository.
>>   > sessionInfo()R version 2.14.1 (2011-12-22)
>> Platform: x86_64-pc-linux-gnu (64-bit)
>> locale:
>>  [1] LC_CTYPE=en_US.UTF-8 LC_NUMERIC=C         LC_TIME=C           
>>  [5] LC_MONETARY=C        LC_MESSAGES=C        LC_PAPER=C          
>> attached base packages:
>> [1] stats     graphics  grDevices utils     datasets  methods   base
>> loaded via a namespace (and not attached):
>> [1] tools_2.14.1
>>  >
>> Thank you,
>>    Gene Leynes
>> _____________________________________________
>> *Data Scientist*
>> *http://www.linkedin.com/in/geneleynes
>> *
>> <http://goog_598053156>*http://geneorama.com/

More information about the R-help mailing list