[R] logical test not functioning correctly on zoo series...what the hell?

knavero knavero at gmail.com
Wed Mar 14 17:14:14 CET 2012

"You're missing a comma between 0 and "]" in the last line if your goal  
is to retrieve the rows that satisfy that condition (and if the  
condition makes any sense). Haven't tested the rest of your code,  


> The outputs that I'm getting, however, are
> printing out 0's down the columns. I've tried various methods assuming
> various theories, read the R manual via "?" for different possible
> solutions, Googled stuff, tried the ifelse function which produces  
> the same
> error, tried creating logical vectors to get a better visual of what  
> the
> process is, tried doing all of the above on a small sample data set  
> (which
> actually works correctly for some reason, but doesn't work on the  
> actual raw
> data), and basically have done a lot of research and trial and error  
> before
> posting on here. Help is much appreciated. Thank you.
> P.S. I hope I asked this correctly on the forum (putting  
> reproducible code
> that reproduces the error, etc.).
... [show rest of quote]

If there is an error then you should post the complete error message."

About to post the error because it's still showing up. I understand the ","
is supposed to act as an (x, y) or (i, j) separator such that [,1] would be
column 1 similar to how rawData$KW.ch..1..set.0. looks at the same column.
Let me know if you're able to retrieve the csv file from the dropbox link.
Again, it should prompt you to download it. I would've put a smaller sample
size, but the logical condition seemed to work on a small scale version
unfortunately, thus being unable to reproduce the problem.

View this message in context: http://r.789695.n4.nabble.com/logical-test-not-functioning-correctly-on-zoo-series-what-the-hell-tp4471654p4472301.html
Sent from the R help mailing list archive at Nabble.com.

More information about the R-help mailing list